Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 16, 2025 - 08:00 UTC
Scheduled
We will be undergoing a scheduled maintenance on remote-access American and European nodes. You may experience a 1- to 10-minute interruption in remote access.
Posted Dec 11, 2025 - 16:57 UTC
This scheduled maintenance affected: America (Services handlers (AWS ECS us-east-1), Remote Access (DO Droplets NYC1)) and Europe (Services handlers (AWS ECS eu-central-1), Remote Access (DO Droplets FRA1)).